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Objectives: 
1. Participants will use at least five visual presentation strategies to accommodate a 

document. 

2. Participants will identify at least two strategies to help students with reading 

difficulties. 

3. Participants will create an accommodated test.  

Differentiating Instruction through Technology 
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Wonders of Word 2007 

 

Start Microsoft Word:  
1. Click on Start, drag up to All Programs.  
2. Drag up to Microsoft Office, choose 

Microsoft Word 2007. 
 

Alternate (No Mouse) 
1. Click on the flying Windows key 
2. Press the P key on the Keyboard, then press the Enter key 
3. Use the down arrow or press the M key until you get to Microsoft Office, press the 

Enter key. 
4. Arrow down to Microsoft Word 2007. 

 
A new document page will open. 
Observe the small blinking insertion line. Typed characters appear next to that line. 
 
 Office Button 
 
Click on the “Office Button” located on the top left corner. A submenu will open which contains 
the following options: 
New- Starts a new document or template. Choose the desired option and click on the “Create” 
button. Ctrl key + N 

 Open- Opens an already existing document.  

 Converts- Converts this document to the newest Word file format. This feature is only 
available if you open a previous version of Word. 

 Save-Is used to save a document for the first time or replaces an existing document with the 
latest changes. You can also click the Save icon from the Quick Access toolbar or Ctrl +S.  

 Save As 
o  Is used to save a document for the first time,  
o Save as a template  
o Save two documents with similar information where the original document 

remains unchanged.  
o Save a document that is compatible to an earlier version of Word 

 Print- Contains three print options 
o Print-allows you to select the printer and number of copies. 
o Quick Print- sends the document to the default printer 
o Print Preview – allows you to see the final copy before printing 

 Prepare- Contains several options for preparing a document for distribution 

 Send – Allows you to email or fax your document. 

 Publish – Several options for distributing document to other people 

 Close- Closes the document but does not Exit the program 



Lourdes Day, FDLRS Sunrise Page 2 May 29, 2008 

 

 
Quick Access ToolBar 

 
This bar contains the three most commonly used icons and may be customized to add your own 
commands: 

 Save OR Ctrl + S 

 Undo Typing OR Ctrl + Z 

 Redo Typing OR Ctrl +Y 
 

Customize the Quick Access Toolbar 
1. Click on the down triangle by the Quick Access toolbar  

2. Click on an unchecked option such as Quick Print so that you 

can print to the default printer without using the Microsoft 

Office Button 

Customize the Access bar further: 

a. Click on the down triangle by the Quick Access toolbar 

and choose More Commands 

b. At the next window click a command on the left and 

click Add 

c. Click OK 

 Remove any command from the Access bar by clicking on the command on the right 

side and choosing Remove 

Ribbon 
The ribbon replaces the toolbars found in the previous versions of Microsoft Office. It is 
designed to bring the most popular commands to the front so you don’t have to search for 
them.  
The ribbon is divided into eight tabs geared to certain activities. Within each tab are groups that 
show related items. Within the group you will find the command button which performs the 
option selected.  

Tabs 

Home- Contains the common format options such as font, font color, size selections, cut, copy, 
paste, format painter, styles and alignment 
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Insert- Contains the options for inserting a new page and page breaks, inserting clipart, picture, 
and charts, tools to create links, insert header and footer, option for text and the equation 
editor 

 
 
Page Layout-Contains the option for creating themes, page setup, page backgrounds (colors, 
watermarks, and borders), paragraph spacing and arrangements 

 
 
References-Contains the table of contents footnotes, citations, captions, indexes and table of 
authorities 

 
 
Mailings-Allows you to create labels, and envelopes, and mail merges 

 
 
Review-Contains spelling and grammar checker, thesaurus, research, translator, comments, 
tracking and changes 

  
 
View-Contains the various screen views, the show/hide (ruler, gridlines document map), Zoom 
and switch windows 

 
 
Add-Ins- This is the ribbon where supplemental programs that you install to extend the 
capabilities of Microsoft Word by adding custom commands and specialized features are 
placed. 
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If you cannot find a certain command you would most likely find them by clicking the small 
diagonal arrow located in the lower right corner of the group. 

 
 
http://office.microsoft.com  
At this website search for an interactive web guide called “Word 2003 to Word 2007 Command 
reference”. This web site allows you to look up the command in Word 2003 and then shows 
you where it is located 2007. 

Minimize the Ribbon 

 
1. Click on the down arrow by the Quick Access Toolbar (located on the top left side of the 

window). 
2. In the sub list, click the Minimize Ribbon. 
3. To use the ribbon while it is minimized, click the tab and then the option you desire. 

*To restore the ribbon return to the sub list on the Quick Access Toolbar and uncheck the 
Minimize Ribbon. 
 
*Control +F1 will quickly minimize and restore a ribbon 
 
Keyboard Access for the Ribbon 

1. Press the Alt key, a set of letters will appear by the ribbon tabs. 
2. Press the letter on the keyboard that corresponds to the desired tab, a set of letters will 

appear by the commands. 
3. Press the letter on the keyboard that corresponds to the desired command. 

*Some commands require that you press the down arrow until you reach the desired option 
and then press the Enter key. 
*Some commands require that the text be highlighted before the command is activated.  
 
Mini Toolbar 
When you highlight text a faded menu with several font options appear. Click on the desired 
option. This is a time saving feature so you don’t have to click back on the home ribbon to find 
the desired feature.  
 
 
 
 

 

http://office.microsoft.com/
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View Ribbon or Status Bar 
There are five ways to view a Word document. These options are located on the View ribbon 
on the lower right corner of the screen.  

1. Print Layout - shows how text, graphics, and other elements will be 
positioned on the printed page. This is the default typing mode. 

2. Full Screen Reading- view the document in full screen for reading and commenting. You 
must click on the Close button (upper right side) to return to the print layout mode. 

 
3. Web View-View the document as it looks on a web page 
4. Outline View- move, copy, and reorganize text by dragging headings. 
5. Draft View-View the documents as a draft to quickly edit text. It is text only. 
*Click the Print Layout button to return to the Default 

 
Recent Documents 
The Recent Document Feature can help students quickly locate frequently used documents by 
pinning them to the menu. By default the recent documents will hold the 17 most recently used 
documents. When the eighteenth document is opened the oldest document will be removed 
from the list. If a student uses a document frequently it is a good idea to have the document 
pinned to the menu so that it is always available. 
 
 

1. Click on the Office Button 

2. A list of Recent Documents will appear on the right 

hand side  

3. Click on the push pin to the right of the document 

and it will turn green to identify that the document has been pinned 

 
Change the Default Number of Recent Documents 

1. Click on the Office Button 

2. Click on Word Options 

3. Choose the Advanced Option 

4. Scroll to find the Display section and change the number up to 50 documents 

 
 
 
Visual Presentation  
There is no formula for the perfect visual presentation. It is based on the student’s individual 
needs. It is evaluated by sitting with the student and asking them when the format of the 
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document becomes clearer and easier for them to read. You may notice that they may copy or 
answer comprehension questions effectively. 
 
Helpful Hints; 

 Type only one space after a punctuation mark.  

 Never type with the caps lock key on. Use the Shift key when making a capital letter. 

 To indent a paragraph, press the tab key once. 

 Press the Enter key only when starting a new paragraph or making a list. Remember word 
processors automatically wrap words to the next line. 

 
Overtype 
This problem occurs when you least expect it and can cause MAJOR frustration. 
The overtype feature will type over any pre existing letter. This feature may turn on if the Insert 
key on the keyboard is pressed unintentionally. To stop the Overtype option, press the Insert 
key on the keyboard. 
 
Zoom 
Magnify the text on the monitor for students who have vision difficulties, visual perception 
problems or specific learning disabilities. This option does not affect the printed document. This 
is a screen tool only. The zoom option allows you to magnify or zoom in on what you see on the 
screen without changing the document font size.  
 

 Click on the zoom option slider located on the lower right side of the status bar.  Drag 

towards the + to increase the text size and towards the – to decrease the text size.  

Alternative 

 Ctrl + the roller ball on the mouse 

Correcting Errors 
Press the Backspace key to delete the characters to the left of the cursor. 
Or 
Press the Delete key to erase characters to the right of the cursor. 
 
Undo Option 
 

 
On the Quick Access tool bar, click on the down curved arrow to correct a mistake you just 
made. 
*Pressing this symbol repeatedly will continue to take you back one step.  
*Click on the down arrow to the right of the undo symbol to see a list of recent actions. Click on 

any items in the list and it will simultaneously undo all the options above it in the list. 
 
Keyboard shortcut - Control Z 
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Redo-The arrow pointing up contains a list of items that were undone. Click on an item you 
wish to have reappeared. 
Keyboard shortcut - Control Y 
 
Selecting or Highlighting text 
Highlight the document or selection FIRST in order to change the font, size, or style. The 
techniques below may be more efficient than dragging. 

Highlight the entire document 

Press the Control key + A. 
OR 
Triple click in the left margin when the cursor is pointing to the right. 
OR 
On the Home ribbon click on the down arrow to the right of Select in the Editing group, 
and choose Select All.  

Highlight a word 

Double click in the word. 

Highlight a sentence 

Hold the control key and click in the sentence. 

Highlight a paragraph 

Triple click in the paragraph.  

Highlight a specific section 

Click in front of the first word to be highlighted. 
Hold down the Shift key and click at the end of the desired section. 
 
Alternative 
Place your cursor at the beginning of the area to be highlighted and hold down the Shift + Right 
arrow to highlight characters 
Shift + down arrow to highlight lines 

Highlight a line 

Click once in the margin to the left of the line. 

Remove the highlight 

Click anywhere in the white area of the document. 
 
Helpful hints: 

 Remember when something is highlighted the next key you press will replace what is 
highlighted. 
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Font - Home Ribbon 

 
 
Click on the Home tab 
In the Font group you may select the font type, style, size, and color and more.  
You may also use the mini toolbar. 
 

Font Choices  

 Use clear, easy to read fonts. Nothing that is to fancy or curly. The Verdana font 
is reported as the font that is most easily read. Elementary teacher may prefer Century Gothic 
because it has the primary a vs. a 

1. Highlight the text.  
2. From the Home Tab, click on the down triangle to the right of the font box and 

choose the desired font. (Or use the Mini Toolbar) 

Font Size  

Increase the font size for students with low vision. Some students with learning disabilities may 
benefit with fonts that are raised to a size 14 or 16.  

1. Highlight the text.  
2. From the Home Tab, click on the down triangle to the right of the Font size 

box and select desired size. (Or use the Mini Toolbar) 

Grow Font- Highlight text, click on the grow font icon until you achieve the 
desire size. (Ctrl + (shift) +>) 
 

Shrink Font- Highlight text, click on the shrink font icon until you achieve the 
desire size.(Ctrl +(shift) + <) 

Clear Formatting 

 If you have made several accommodations to a document that doesn’t seem to be working 
reset the document back to plain text 

1. Highlight the text.  
2. From the Home Tab, click the Clear formatting feature to remove all formatting. 

Bold  
Draw attention to items such as vocabulary words, directions, due dates and main ideas by 
bolding the text. 

1. Highlight the text.  
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2. From the Home Tab, click on B, (Ctrl + B) (Use Mini Tool Bar) 

Underline 

Underline text to emphasize items of importance. Use this option sparely so that it doesn’t 
clutter the page 

1. Highlight the text. 
2. From the Home Tab, click on U. (Ctrl key + U). 
3. Click on the down arrow next to the U icon to select from various underline 

options. (Use Mini Tool Bar) 
 
For more font features click on the diagonal button located to the right of the word Font. A 
Font menu will appear. 

 

Text Color  

Add visual interest, draw attention to text and for some students make the 
document easier to read. 

1. Highlight the text. 

2. From the Home Tab, click on the down arrow next to the Font 

Color and choose the desired color. (Use Mini Tool Bar) 

Change all of the same word to a specific format  
1. From the Home tab choose Replace  

2. Type the word you want to format in the “Find what” Box 

3. Type the same word in the “Replace with” box 

4. Highlight the word in the “Replace with” box  

5. Click on the More button and the window will open  

6. Click on the Format button located in the lower part of the 

window and choose Font 

7. In the Font window choose your color and click OK. 

8. Click on Replace All 

9. A message will appear informing you of the total number of 

words which will be changed. Click OK. 

Background Color  

Some student with Scoptopic Sensitivity Syndrome as well as some student with low vision may 
benefit from changing the background color and adding a contrasting font color. 

1. Click on the Page Layout tab 

2. Click on the down arrow by Page Color. 

3. Choose the preferred page color. 
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*A black background with yellow or white font gives the greatest contrast and works 

well with student with low vision. 

*Blue is reported as the preferred color for students with learning disabilities 

*Yellow and red (intense colors) is the filter of choice for many students with attention 

disorders. 

Changing the Font Default 

Word comes with a default font of Calibri font, size 11. To change the default of your font, size, 
and style. 

1. From the Home tab, display the Font menu by clicking on the diagonal button to the 
right of the Font word. (Ctrl + D) 

2. Choose on the desired options in the window and click on Default button.  
3. A window will appear informing you of the change for all new documents.  
4. Click on Yes to accept the new default. 

 

Line Spacing  

 Increase the white space between the lines to makes the document easier to read. 
1. Highlight text  
2. Click the down arrow to the right of the line spacing command and 

choose the desired option.  
 Press the Ctrl + 2 for double spacing. 

 Press the Ctrl + 5 for 1.5 spacing. 
 Press the Ctrl + 1 to return to single spacing.  

If you do not see the feature you want click on the “Line Spacing Options” from 
the menu 

o Click on the line spacing down arrow and choose Exactly. In the At box 
type the amount of space desire between the lines or use the up/down 
arrows. 

Character Spacing  

Increase the character spacing to assist students who have difficulty distinguishing 
where one letter ends and the other begins. 

1. Highlight the text. 

2. From the Home tab, click the diagonal arrow by the word Font. 

3. At the Font window click the Character Spacing tab. 

4. At the Spacing box, use the dropdown arrow and choose Expanded. 
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5. In the By box use the up/down arrow to find the preferred amount of spacing. 

6. Click OK. 

Word Spacing  

Increase the amount of space between each word to help students distinguish where one word 

ends and another begins.  

1. Highlight the text 

2. From the Home Tab, choose the Replace option. 

3. In the Replace box press the space bar ONCE. 

4. In the Replace With box press the space bar 2 or 3 times depending on 

the need 

5. Click Replace All. 

6. You will see a window that informs you of all the instances that are affected by 

the change. 

7. Click OK. 

 Keyboard Shortcut Ctrl Key  +H 

 

 

Margin Increase  

Increase the amount of white space in the left and right margin to decrease the amount 

of visual tracking a student will have to do. 

1. Click on the Page Layout tab. 

2. Click the down arrow below the Margins option. 

3. Choose Custom Margins. 

4. Type in the preferrred margin size in the left and right box 

5. Click OK.  

Writing 
Auto Correct 
The Auto Correct option may be used in two ways. The first is to assist students that consistently 
misspell the same word. Example they spell wuz for was. This avoids then having to constantly 
deal with the red underline word.  
 
The second is for abbreviation expansion. This feature lessens the amount of keystrokes a 
student has to press in order to type out a word or phrase. Example XLD may expand to type out 
Lourdes Day. The idea of placing an X in front of an abbreviation came from Scott Marfililus who 
suggested this in case you want to type just the abbreviation.  
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Common Misspelled Words  

1. Click on the Office button. 

2. Choose Word Options (located in the lower left of the window. 

3. Click Proofing. 

4. Select the AutoCorrect Options. 

5. In the “Replace” box type the misspelled word. (wuz) 

6. In the “With” box type the correct word. (was) 

7. Click OK. 

Abbreviation Expansion  

1. Open the AutoCorrect Options as above. 

2. In the “Replace” box type, X and the initials. Example XLD or XFDLRS 

3. In the “With” box type the whole word or phrase.  Example Lourdes Day, or Florida 

Diagnostic and Learning Resources System. 

4. Click OK. 

5. When you return to the document type the abbreviation and press the space bar to get 

the expansion. 

Auto Text 
Auto Text is an option that can be used to store complete paragraphs or information that is 
typed often. This will reduce the number of keystrokes a student who is physically challenged 
will have to type.  
 
 An example of a paper heading is below. 

 
 

 

Add Command to Quick Access Toolbar  

First you must add the Auto Text feature to the Quick Access toolbar. 
1. Click on the down triangle by the Quick Access toolbar and choose More Commands 

2. At the next window click on the down arrow by 

Popular Commands and choose All Commands  

3. Scroll to find AutoText in the left column, click to 

select it and click Add  

4. Click OK  

5. You will now see the AutoText icon on the Quick Access Toolbar located in the top left 

corner of your screen.  

Lourdes Day       May 29, 2008 

Period 3       Math 
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Save and Use AutoText 

Next  
1. Type the heading or paragraph you want to be able to quickly access. 

2. Highlight the selection. 

3. Click the down arrow by the “AutoText icon”. 

4. Choose “Save Selection to AutoText Gallery”. 

Use the Saved Selection 

1. Click the AutoText icon.  

2. lourdes.dayChoose the Quick Access toolbar and click on your 

selection. 

Delete from AutoText 

1. Click on the down arrow by the AutoText icon on the Quick Access 

Toolbar and drag to the entry to be deleted 

2. Right click on the Entry and choose Organize and Delete 

3. A window will open, scroll to find the entry and click on it to select 

4. Click on the Delete button. A message will appear confirming the deletion, click 

OK  

5. Click Close 

 
Spelling and Grammar - Review Ribbon  
Red underlines – Misspelled word 
Green underline- Grammar error 
Blue underline- Contextual Spelling error (These are words that are 
flagged because they are words used in the wrong context.  
Spell Check Methods: 
Right click on the underlined word and choose the correct word from the sub menu. 
OR 
Keyboard Shortcut for spell check-Press the f7 key  
OR 
Click on the Proofing Errors icon the Status bar in the lower left corner 

 
 
OR 
 

1. Click on the Review Tab. 
2. Click on the Spelling and Grammar option 
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3. At the Spelling and Grammar window a list will appear in the suggestions box.  
4. Double click on the correct spelling or grammar option  

*You may also single click on the correct option and click on Change.  
The Grammar checker will tell you what kind of grammatical error was made such as an extra 
space. It will also pick up on some commonly confused words such as there and their. However 
not all errors are recognized so you must proof read all your work. You may choose to ignore or 
change the errors. 
 
If you have students that get frustrated by seeing all the red, blue, and 
green lines that identify their errors as they type, turn the feature off by: 
Clicking on the Spelling and Grammar option from the Review tab and 
then clicking on the Options button.  
 

 From the menu uncheck from the “Check spelling as you type” 

and “Mark grammar errors as you type”. (This affects the current and future Word 

documents) 

 From this menu you may also choose to turn off this feature for just the current 
document by clicking the “Hide Spelling or Grammar errors in this document only” in the 
Exceptions Section. 

 
Readability Statistics 
Readability statistics will give information about the reading level of the document, including 
approximate readability scores and grade level. 

a. Readability is rated on the average number of syllables per word and words per 
sentences. 

b. Grade level  
Microsoft’s help guide explains grade level as; “Rating 
text on US grade-school level. For example: a score of 
8.0 means that an eighth grader can understand the 
document. For most standard documents, aim for a 
score of approximately 7.0 to 8.0.” 

c. Reading Ease  
Microsoft’s help guide explains reading ease as; “Rating 
text on a 100-point scale; the higher the score, the 
easier it is to understand the document. For most 
standard documents, aim for a score of approximately 
60 to 70.” 

 
 
 
 
 
 

Score mapping table: 

Flesch Reading  

Ease Score 
  

Readability  

Level 

0 - 29  Very difficult 

30 - 49  Difficult 

50 - 59  Fairly difficult 

60 - 69  Standard 

70 - 79  Fairly easy 

80 - 89  Easy 

90 - 100  Very easy 
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To display the readability statistics  

1. Click on the Office Button and choose Word Options 

2. Click on Proofing  

3. Check Readability Statistics 

OR 

1. Click on the Review Tab  
2. Click on Spelling and Grammar option 
3. Click on the Options button 
4. Click on “Show Readability Statistics” 

 
Thesaurus  
Students may know a variety of adjectives such as wonderful and fantastic but will often use the 
same description words such as good/great because they are words they are comfortable 
spelling. The Thesaurus gives a list of synonyms for the word that is highlighted and introduces 
or reminds students of other adjectives. 
 

 Right Click on a word, choose Synonym and click on the desired word. 

OR 

 Keyboard Shortcut Shift + F7 

 

OR 
1. Highlight a word  
2. Click on the Review Bar 
3. Click on the Thesaurus option 

 
 

Footnote and Endnote  
Use footnotes and endnotes to clarify instructions, give definitions, helpful 
hints, check comprehension or even let the student know what to do next.  
Footnotes appear at the bottom of the page, endnotes appear at the end of 
the document.  

1. Choose the Reference Tab. 

2. Place your cursor where you want the reference number to 

appear. 

3. Click on the Insert Footnote icon (Alt+ Ctrl +F) or Endnote (Alt + 

Ctrl + D).  
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4. The student will see the footnote on the bottom of the page or they 

may lay their cursor on the footnote or endnote number and see the 

text that was typed. 

 
Show and Hide Format  
Turn on the Show/Hide feature so that a student can self check the format of their work. A dot 
will appear between each word to represent when the space bar was used. An arrow pointing to 
the right will represent the tab key. A backwards P represents the Enter Key being used. 
 

1. Click on the Home Tab 
2. Click on the Show / Hide  
3. You will see the formatting marks that symbolize your actions.  
4. You can add or delete the formats as necessary. 

 
Shortcut-  Ctrl+ Shift + * 

 
Align Text  
Type the text 

Left Align = Ctrl key + L 
Center Align= Ctrl Key + E  
Right Align= Ctrl Key + R 
Justified = Ctrl Key + J 

 
Alternative 

1. Click on the Home tab 

2. Choose from any of the alignments in the Paragraph group 

 
Change Case  
If a student accidently types with their “Caps Lock” key on, you can easily correct the error using 
the following methods 

1. Highlight the text. 

2. Choose the Home Tab 

3. Click the down arrow to the right of the Change Case icon and click on the desired 

selection. (Sentence case, lowercase, UPPERCASE, Capitalize Each Word, tOGGLE 

cASE) (Keyboard shortcut - Shift + F3) 

Note the computer is set to default all first letters to capitalization including words you type in 
a list. 

To remove this option:  
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1. Click on the Office Button 

2. Click on the Word Options button 

3. Click on Proofing (Left side menu) 

4. Click on the Auto Correct Options 

5. Uncheck the box to the left of Capitalize first letter of sentence. 

Smart Graphics  
Visual organizers help students to study and organize information for writing. Word 2007 
contains basic organizers for creating list through more complex Venn Diagrams 
 

 
1. Select the Insert tab. 

2. Click on the SmartArt icon. 

3. Click on the desired graphics and click OK. 

Move the Smart Art by:  

Right clicking on the item 

Choose Text wrapping – Either Tight or Square 
4. Type the desired text in the graphics. 

 

 

When you select the SmartArt item, a SmartArt Tools Design and Format ribbon will appear 
that allows you to further customize the SmartArt design.  

 

Fish

gills

water

Elephants

Skin

land

Birds

Feather

air
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Track Changes  
The “Track Changes” feature allows students and teachers to interactively edit a document on 
the computer. The teacher or even another student may suggest changes and then the author of 
the text may choose to accept or reject the changes. The teacher can monitor the comments 
and changes as the document progresses. 

1. The author types the document. 

2. The editor chooses the Review tab and clicks on the Track Changes icon (Ctrl + Shift + 

E). The button will highlight to indicate it is on. 

3. The editor types suggestions which will appear in red. 

4. The comments button may be used to add a statement explaining the changes. 

5. The author then chooses the Track Changes icon again to turn off the tracking feature. 

6. The author may accept or reject the changes, by either: 

a.  Right clicking on a suggestion and choosing to Accept or Reject the changes.  

b. Or use Accept or Reject button on the Review ribbon. 

7. In order to see the document without all the marking, click on the arrow 

by the “Final Show Markup” icon and choose Final.  

 Bibliography 
This feature allows the students to gather the required information about the sources they used to write 
a report and then have Word automatically create a Bibliography 

Create Citations 

1. Place the insertion point at the end of the cited paragraph  

2. Click on the References tab 

3. Click on the Style option and choose the style for the citation (APA, MLA, 

Chicago…) 

4. Choose the down arrow by Insert Citation and Click on Add New Source 

5. Click the down arrow by the Type of Source and choose the type of item to 

be cataloged and complete all the fields on the window 

6. Click OK 

7. You will see the a reference place at the end of the paragraph for 

example   (The White House, 2008) 

Insert a Bibliography 

1. Click where you want to insert the bibliography 

2. On the Reference tab click Bibliography 

3. Choose either Bibliography or Work cited 
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Examples: 
Bibliography 
Shakespeare, W. (1590). Romeo and Juliet. London: Works Press. 

The White House. (2008, Feb 4). Retrieved Feb 4, 2008, from The White House: www.whitehouse.gov 

 

 
Works Cited 
Shakespeare, W. (1590). Romeo and Juliet. London: Works Press. 

The White House. (2008, Feb 4). Retrieved Feb 4, 2008, from The White House: www.whitehouse.gov 

 

Edit Manage Sources 

When you create a new document you may wish to use some 
previously created sources in the Bibliography 

1. From the References tab choose  Manage Sources 

2. Click on the desired source on the Master list and click Copy. 

You will see on the current list 

3. When all the sources are on the current list follow the 

directions for inserting a bibliography 

 
 
Save 
To save a document for the first time: 

1. Choose one of the three options below:  

a. Click on the Save Disk  (located in the top left of 
the screen, Quick Access Bar OR  

b. Press Ctrl + the S Key, Or  
c. Click the Windows Office Button and choose Save  

i. At the submenu, choose Word Document or 
other format. 

2. At the Save As window, click on the triangle to the right of the Save in box. Choose the 
appropriate destination for your document. 

3. At the File name box drag over to highlight the title in the name box and title your 
document something you will easily remember.  

4. Press the Save button. 

 To save an edited document-Click the Save icon or press the Ctrl + S.  This will 
replace the earlier version with the latest changes.  

*To Save the same document but with a new name use the Save AS command from the 
Windows Office Button.  You may then choose the location for the document and rename the 
new copy. 
 
Helpful Hints; 

 By default most Microsoft documents will save into the “My Documents” folder.  
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 If the machine is going to be used by several students and/or teachers it may be a good idea 
for each person to have their own flash drive to save their work. This will prevent your hard 
drive from getting cluttered. 
 Do Not use “, : , /,| *,?,<,> in the title. Word will not accept this symbols as the file 

name. 
 
You may specify how often Word will automatically save a document. 

1. Click the Windows Office Button and choose the Word Options feature 

located at the bottom of the menu. 

2. Choose the Save option in the left task pane and then type how often you want Word to 

Save. By default it is set to save every10 minutes. 

 
 
 
Save As PDF Or XPS 

1. Click on the Office button and choose Word Options  

2. Click on Resources 

3. Click the button by Go to Microsoft Office Online 

4. Click on the download tab and search for PDF in the download search box 

5. Choose 2007 Microsoft Office Add in: Save AS Microsoft PDF or XPS 

6. You will see a validation screen click Continue and follow the download directions. 

Several screens later Choose Run in order to install the software 

  
Convert any word document by: 

1. Click on the Office button and choose Save As 

2. Select PDF or XPS. 

 
Reading 
 
 If you need to have an entire document read you may want to download a free program called 
Natural Readers. This may be downloaded from www.naturalreaders.com. The free version uses 
the robotic voices that come with your windows system. You may purchase a much better voice 
for $39.95 from this website. It would be worth the upgrade if a student needs the auditory 
input to go along with the visual text. Natural Reader reads not only Word documents but also 
emails, and the internet. Highlight the selection, click the read selection (right arrow) and it will 
read what is highlighted. The program also provides an auditory word processor for students 
who need to hear what they are typing.  

Voice Note 

A voice note allows you to record your voice on a document to assist students who have 
difficulty with decoding or comprehension. You may use this to read passages, and test 

http://www.naturalreaders.com/
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questions. Students who have fine motor problems could be taught to use this feature to answer 
questions orally. 
 
Create a Voice Note: 

1. Choose the Insert Tab 

2. Click on the down arrow by Object (far right of side of the ribbon).  

3. Choose Object 

4. At the window, scroll to find Wave Sound and click to select it. Click OK 

5. At the Sound window click the red button to record, the black button to stop, 

and the left arrow to rewind/playback. 

6. When you close the window a speaker symbol will appear.  

 

*To hear the voice note: double click the speaker symbol  

Proofing (Definitions, Synonyms, Translation) 

Students who are unsure of the meaning of a word can quickly get the definition or the 
translation of a word. This feature helps with both reading and writing. 
 

1. Highlight a word. (If you use this several times in the same document you 

will have to press the green arrow next to the search for word to change 

the selection). 

2. Click on the Review tab. 

3. Choose the desired icon. Research, Thesaurus, or Translate. 

4. A task pane will open to the right.  

5. Click on the down arrow next to second line and choose the preferred 

Reference Book. (Encarta Dictionary, Thesaurus in English, Spanish or French, 

Translation or Encyclopedia). 

Alternative 
1. Right click on a word  

2. At the submenu choose Lookup (Research), Synonyms (Thesaurus) 

or Translate. 

 If you right click on a word and choose Translate you have the 

option to turn on a translator. 

 While it is on lay your cursor on a word and a screen tip with the 

translation will appear  

 Turn it off by right clicking on a word and choosing “Turn off 

translation screen tip”  
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ClipArt  
Clip art adds visual supports to documents by providing an image for a new concept or 
vocabulary word. Pictures with a globe on the left side reside on the internet and are only 
available if you are connected to the web. Pictures with a star mean it is an animated giff and 
will move in programs such as PowerPoint. 
 
Adding Clip Art - Insert Ribbon  

1. Place your cursor where the picture will be inserted 

2. Click on the Insert tab 

3. Click on the Clip Art icon 

4. A Clip Art task pane will open on the right hand side of the screen. 

5. Type the name of the picture you are looking for in the “Search for:” box. 

6. Click Go or press the Enter key. 

7. Click once on the image you want to insert. It will place it where ever your 

cursor is located. Images with a yellow star indicate they are animated gifs 

so they move in a PowerPoint Presentation. 

Picture Tools/Format Option - Format Ribbon  
In order to show the Picture Tools/Format ribbon you must double click on a picture. The tab 
will appear after the Add-Ins tab. 

Move Picture 

A picture may be moved by clicking in the center, holding the mouse button down and dragging 
the picture to a new location. However there are times the picture will not move to the exact 
desired location. In this case you may want to follow the text wrap directions below.   

Text Wrap 
1. Right click on the image.  

2. Choose Text Wrap from the sub menu. 

3. Make your selection. 

4. Click OK. 

 
Alternative 

 
1. Double click on the picture to select it. (Notice that from any ribbon if the picture is 

selected the Format/Picture option will appear after the Add-Ins tab). 

 
 

2. Click on the down arrow to the right of Text Wrapping feature 
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3. At the submenu choose, Square to have the text wrap around the picture in box shape, 

or use Tight if you want the text to wrap using the image shape. 

4. Click in the center of the image and drag the picture to the preferred location. 

Resize Picture 

1. Click on the picture to select it.  Resizing handles will appear. 

2. Click on one of the corner handles and drag diagonally towards the center to 

decrease the size of the picture. 

3. Click on one of the corner handles and drag diagonally away from the center to 

increase the size of the picture. 

Alternative method 
 

1. Double click on the picture to select it. 

2. Click on the down arrow next to the Size. 

3. From the Size group on the Picture Tools Format ribbon, 

highlight the Scale - Height box and type in the desired size. 

4. Click OK. 

OR 
1. Right click on the picture  
2. Choose size 
3. Type in the size in the height box  
4. Click Close  

 

Make Clips Available Offline 
1. From the Clip Art Task Pane place your cursor on the desired picture 

2. A down arrow will appear on the right side of the picture 

3. Choose Make Available Offline 

4. Pick the Favorite Category and click Ok  

5. When you press the command you will see the picture on the task without a globe in the corner 

 
AutoSummarize 
Microsoft defines the AutoSummarize option as the following: AutoSummarize identifies the key 
points in a document for you to quickly scan or share with others.  The AutoSummarize feature 
works best on well structured documents, reports, articles, and scientific papers.  
Often times when students encounter large documents the text may be overwhelming. Using 
the AutoSummarize feature allows the teacher or the student to create an “Executive  
summary” which allows the student to preview what they are about to read. 
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Add the AutoSummarize Feature to the Quick Access Toolbar 

AutoSummarize is not part of the ribbon therefore it MUST be added to the Quick Access 
Toolbar 

1. Click on the down triangle by the Quick Access toolbar and choose More Commands 

2. At the next window click on the down arrow by 

Popular Commands and choose All Commands  

3. Scroll to find AutoSummary in the left column, 

click to select it and click Add  

4. Click OK  

5. You will now see the AutoSummary icon on the Quick Access Toolbar located in the 

top left corner of your screen.  

Use AutoSummarize  

1. Click on the down arrow by the AutoSummarize icon on the 

Quick Access toolbar.  

2. Choose any of the four options.  

a. Highlight key points-highlights the important points 

on the document itself 

b. Create a new document and put the summary there-Opens a new word 

document and places the summary there. 

c. Insert an executive summary or abstract at the top of the 

document- places the summary at the top of the text. This 

would be a good preview of the text a student is about to read. 

d. Hide everything but the summary without leaving the original 

document - Hides everything except the summary.  

* Set the length of the summary by choosing it from the drop down on 

the menu. 

 

Study Skills 
Teach students the use of highlighter tools. This strategy can be used to find important 
concepts, identify new vocabulary words, distinguish between nouns, verbs or other parts of 
speech, sort main idea from details, categorize items and mark concepts that may need 
clarification. 

 
Highlight Text 
1. Choose the Home tab. 

2. Click the down arrow by the “Highlight text” option and choose a color.  

3. Drag through the text to highlight.  
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(Or click the highlighter on the mini toolbar) 

 
 Remove the highlight: 

1. Drag over the text that is currently highlighted 

2. Click on the down arrow to the right of the Text Highlight icon and choose “No Color”. 

Stop the Highlight – Click on the highlight tool again from either the Home tab or the mini 
toolbar 
 
Numbering  
Number items in list to show the order of importance or to help students understand what must 
be done first. 
 

1. Type and then highlight a list. 

2. Choose the Home tab. 

3. Click on the “Numbering” option or use the down arrow by the option to 

choose a different numbering style. 

*You can also type the first item in the list and then choose the numbering option. When 
you press the Enter key the next item on the list will be numbered. 
*To stop the numbering, press the numbering icon again.  
 
If you need to create an Outline look: 

1. Type point number one with the number option turned on. 

a. Decrease indent-  Bring the point further to the left ( Keyboard Shortcut 
press the Shift key + Tab) 
 

b. Increase Indent brings the point toward the right (Keyboard shortcut press 
the Tab Key) 

 
Bullets 
Use the “Bullets” option to identify important points on a document. 
 

1. Choose the Home tab 

2. Click on the down arrow to the right of the “Bullet” icon to choose a 

different bullet.  

3. Click on the “Define New Bullet” option at the bottom and then chose 

“Symbol”.  

4. Under the Font menu there are several font options that have great bullets. 

Example Webding and Wingding.  
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5. Click on the desired symbol and then click OK (twice). 

6. Use the check box bullet to create a “To Do List” students may use. You will find the 

check box in the Wingding font menu. 

Sort/Alphabetize 
1. Highlight a typed list. 

2. Choose the Home tab. 

3. Click on the Sort icon. 

4. At the next window click the down arrow below 

“Sort by”. 

5. Choose Field 1 

6. Click OK.  

 

Document Map  
A document map is a separate pane that may serve as a quick guide through a long document. 
You may type questions for students to think about during reading or heading titles to give them 
a quick guide (similar to a table of contents). You may even type both headings/questions if you 
choose. 
 

 
 
First you must create/type the headings or questions. 

1. Type text that will serve as headings or questions. 

2. Highlight the heading or question and click on the Home tab. 

3. Choose Heading 1, Heading 2 or Heading 3 from the 

Style grouping. 

Show the document map 
1. Choose the View Tab. 

2. Click to check the box next to the Document Map option in the 

Show/Hide group.  

3. A task pane will open on the left. 
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4. Click on either the heading or the question and the cursor will move to that location 

on the document. 

Close the document map by either clicking on the x in the task pane or unchecking Document 
Map from the View tab. 

 
Full Screen Reading View 
The reading view may be an easier format for students to research vocabulary or concepts, 
highlight important points and translate single words into Spanish and French as they read.   
 

 
 

1. Click on the Full Reading View located on the status bar in the lower right corner 

2. From the Reading view, click on the down arrow by the Tools feature (upper 

left corner) and select research, translate, highlight, comment or find. 

*Click on the Close button located on the top right corner of the screen to return 
to the print layout view. 

 
Hyperlinks  
Hyperlinks are a great way to help students navigate the Internet and to help limit their 
research to specific sites. 
Keyboard shortcut Ctrl +K 
Or 

1. Highlight or select the text or graphic to be hyperlinked  

2. Right click on or selected text or picture and choose Hyperlink 

3. Highlight or select the text or graphic to be hyperlinked 

Or 
1. Highlight or select the text or graphic to be hyperlinked  

2. Click on the Insert Tab and choose Hyperlink 

3. Highlight or select the text or graphic to be hyperlinked 

Flash Cards 
This is a great idea from Judy Sweeny (www.onionmountaintech.com), for using the table 
feature to create flash cards. This strategy reinforces vocabulary words, math skills and new 
concepts. 

http://www.onionmountaintech.com/
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1. From the Insert tab click the down arrow below the Table icon. 

2. Select the number of rows and columns needed for your flash cards. For 

example six cards require 3 columns and 4 rows. 

3. Insert the pictures in row 1 and 3. 

4. Type the name of picture in rows 2 and 4. 

5. Highlight the entire table by dragging through all the cells. 

6. Right click in the highlighted table and choose Table Properties. 

7. Click on the Row Tab and type the desired height in the “Specify height” box. 

Example 2. In the “Row Height In” box choose “Exactly” from the drop down 

menu. 

8. Click on the Column tab and type 2 in the “Preferred width” box. This will create 2” * 2” 

cells. Click OK. 

9. Center the words by: 

a. Highlighting the row with the words. 

b. Right clicking and choosing Cell Alignment.  

c. Choose the center alignment option. 

10. Change to the preferred font size and font if needed.  

Test Taking 
If a student has visual perception problems they may have difficulties matching an answer in a 
word bank to the correct question. Create test on the computer that contain Drop- Down 
menus. 
 
Table 
Create a table to easily align choices in a word bank 

1. Click on the Insert Tab 

2. Click on the down arrow by Table  

3. Drag across as many columns and cells as choices in the word bank 

 

To make the cells automatically expand to fit the content of the cells 

1. Click on the table layout tab 

2. Choose the Autofit icon 

3. Click on Autofit to Window  

 
 
In order to create and protect documents with special features you will need to add the 
Developer tab. 
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Developer Ribbon 

 
1. Click on the Microsoft Office Button. 

2. Choose the Word Option located in the bottom right corner 

of the menu. 

3. At the next Window, choose “Popular”. 

4. Select “Show the Developer tab in the Ribbon” check box. 

Click OK. 

5. Notice the Developer ribbon is now a part of the original Microsoft Office Ribbon. 

 

  
 
Content Control 
Once the Developer tab becomes available you will be able to specify and control the 
data that goes into the selected fields. 
 
*Any field that requires a response must be marked with a text form field, check box 
form field, OR a Drop-Down form field.  Once a document is protected, only areas that 
contain a form field will be able to be completed. The document cannot be changed 
and no additional typing will be allowed outside the designated form fields. 

Text Form Field 

1. Place the cursor where the participant will type their response 

2. From the Developer tab click on the down arrow by the Legacy Control (Looks 

like a tool box) and choose “Text Form Field” (ab) option. 

a. Double click on the inserted “ab” (gray box) to bring up the “Text Form Field 

Option” Window”. This allows you to further manage the 

field.  

b. Click the down arrow below the “Type” option to specify 

what type of data may be entered into the field. (Text, 

Number, Date…) 

c. Once you have made the selection you can further specify 

formatting by clicking the down arrow below “Text Format” “Maximum Length” 

and making a selection. Click OK when the formatting is complete. 

Check Box 
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1. Place the cursor where the check box will be inserted.  

2. From the Developer tab click on the down arrow by the Legacy Control and 

choose the “Check Box Form Field” option. 

a. Double click on the inserted “Check Box Form Field” to bring up the 

“Check Box Form Field” Fields Options” window to make further 

specification to the check box.  

b. By default the check will NOT be checked. Make your selection and 

click OK. 

Drop Down Form Field 

1. Place the cursor where the drop down menu will be inserted.  

2. From the Developer tab click on the down arrow by the Legacy Control and 

choose the “Drop Down Form Field” option.  

a. Double click on the inserted Drop Down Field to bring up the “Drop –

Down Form Fields Options” window.  

b. Type the text in the “Drop-Down Item” box and click on Add or press 

the Enter key.  

c. Click OK when the list is complete. 

*Helpful Hints 

 Never start the list with a possible choice, instead start with something such as: Click 

here, Choose… 

 Edit a created field by double clicking on the inserted field so that the options window 

will reopen. 

 Once the form is protected it cannot be edited until it is unprotected. 

 If the drop down list will be used in multiple fields copy and paste the drop down list in 

the other areas. 

  Copy and Paste 
Right click on the field to be copied and choose Copy. 
Right click where the copied drop-down menu should appear and choose Paste. 
Continue to move the cursor to the new location and right click and paste until 
all the desired fields have been filled. 

Text Box 
A text box is a great place to write directions. Using this tool will allow you to quickly make 
borders and attract the eye to this important information 

1. Choose the Insert tab 

2. Click on the down arrow below the Text Box option 

3. Choose Draw Text Box Type in directions 
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*You can move the box by dragging the box to the desired location. Resize the box by 

dragging the resizing circles. 

4. Your cursor will become a crosshair. Click hold and drag out a box 

5. Type the desired text 

Text Box Borders & color 

Make the border thicker  

1. Select  the text box 

2. Click on the last tab - Format  

3. A tool bar will appear 

4. Click on the Shape Outline and drag to Weight 

5. Choose the desired thickness 

6. From this menu you may also click on a preferred border color 

Cue Shapes 
Use stop signs, call outs and even smiley faces to encourage students or remind them of 
directions.   

1. Choose the Insert Tab 

2. Click on the down arrow by the Shapes options 

3. Click on the desired shape 

4. Click, hold and drag until the desired size of your shape is achieved. 

* You may type in most shapes if you right click on the shape and choose Add Text.  

*Callouts allow you to just click in the shape and type 

 
Protect the Document 
Before saving the form as a template it is a good idea to test to be sure all the fields 

work.  

*Be sure you are NOT in the Design Mode on the Developer Tab. 

 

1. From the Developer tab click on the down arrow by “Protect Document”. 

2. A submenu will open; choose “Restrict Formatting and Editing”. 

3. A task pane will open on the right side of the screen.  

4. By number 2, Editing Restrictions click the box by “Allow only this type of 

editing in the document:” 

5. Click on the drop down menu and choose “Filling in forms”. 

6. Click on “Yes Start Enforcing Protection” 

7. A password window will open. You will be asked to type a password 

twice. Once the document is protected it can NO longer be edited 

unless you unprotect the form.  

Think About …. Stop 



Lourdes Day, FDLRS Sunrise Page 32 May 29, 2008 

 

8. Click OK. 

Test the form by pressing the tab key to be certain the cursor only goes where you want text 
entry. 
 
Unprotect the Document 

1. From the Developer Tab click the “Protect Document” icon and then click “Restrict 

Formatting and Editing”. 

2. In the Protect Document task pane click on “Stop Protection”. 

3. You will be asked to enter your password and press OK. 

4. The document may now be edited. 

Save as a Template 
It is a good idea to protect and save the newly created form as a template. 
Be sure the form is protected before proceeding. 

1. Click on the Office Button and choose Save As. 

2. At the submenu choose Word Template. 

3. At the Save As window, choose the location for your template and then name the file. 

4. Click Save.  

Notice that Template documents have a yellow band at the top, where as a 
regular document has the top right corner “dog eared” 
 
 
 
 
 
 
Working with a Template vs a Document 
 
Making corrections on the original template 
To edit the template, right click on the template and choose Open. 
You should see the name of the template on the title bar. 
 
Filling in Information 
To use the template, double click to open it. 
You should see the word “Document” with number beside it on the title bar. 

Regular 

Document 

Template 
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Keyboard Shortcuts 
Mac Use the Apple key for Ctrl 

Ctrl + A = Highlights the entire document 

Ctrl + B = Bold 

Ctrl + C = Copy 

Ctrl + D=Duplicates clip art 

Ctrl + E = Align Center 

Ctrl + F = Find 

Ctrl + G = Go to  

Ctrl + H = Replace 

Ctrl + I = Italics 

Ctrl +J + Justify 

Ctrl + L = Align Left 

Ctrl + K =Hyperlink 

Ctrl + N = New document 

Ctrl + O = Open document 

Ctrl + P = Print document 

Ctrl + R = Right Align 

Ctrl + S = Save document 

Ctrl + U = Underline 

Ctrl + V = Paste 

Ctrl + X = Cut 

Ctrl + Y = Repeats typing 

Ctrl + Z = Undo 

Ctrl + F1=Minimize/Restore Ribbon 

Ctrl + > = Grow Font 

Ctrl + < + Shrink Font 

Ctrl + = =Subscript 

Ctrl + + =Superscript 

Ctrl +1 = Single Space 

Ctrl + 2 = Double space 

Ctrl + 5 = 1 ½ lines of space 

Ctrl + Turn the mouse wheel = magnifies text on screen 

Ctrl + * = Show/ Hide 

Control + F6 = switches between Documents 

Tab=Increase Indent 

Shift +Tab = Decrease the indent 

Shift + F3= Change Case 

Double Click = highlights a word 

Ctrl + click in the sentence = highlights the sentence 

Highlight a section by click in front of the section, hold the shift 
key and click after the desired section 
F1 = Help 

F7 key = Spell check 

Right click on a misspelled word =drop down menu 

Macintosh Command +click the mouse on misspelled word 

F7 + Shift key = Thesaurus 

Right click on a word and choose synonym 

Control +ALT + Delete = Restarts a frozen computer 

Restart a frozen windows machine Control + Alt = Delete key. 

ALT + F4 = close a document 

Alt Key (letters appear), press the corresponding letter to the 
desired ribbon, press the letter corresponding to the desired 
command 
Ctrl +’ = Accent Mark José 

Ctrl + Shift + ~ = Tilde niña 

Ctrl + Shift + : = Umlaut ö 

Shift + Colon , Shift + Zero = 

Shift + Colon , Shift + Nine= 

Shift + Colon +\ =  

Ctrl + Shift + =       Superscript  52 

Ctrl + =       Subscript  H2o 
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Ideas for Designing Assignments and Assessments 
  

 Clear uncluttered format – more white space between lines, characters, words and 

margins 

 Fewer items on a page 

 Leave enough room for students to write answers 

 Enlarge margins to shorten tracking field 

 Larger and clearer fonts 

 Never type in all caps or italics 

 Clear simple directions- Bold directions  

 Underline, bold or use different colors to highlight key words in directions and passages 

 Use symbols such as arrows and stop signs to clarify directions 

 Give examples and non examples-set apart in a box 

 Use fill in the blanks question with Word Banks  

 Multiple choice questions with 3 to 4 choices. Avoid “not” questions 

 Change font or background colors to enhance visual perception 

 Use borders around word banks and between sections 

 Use color coding to identify tasks, definitions, or directions 

 Allow the use of spell check and a thesaurus when appropriate
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This rubric was created by Matthew Press, Arizona Dept. of Education  1535 W Jefferson Phoenix AZ 85007  602-364-3243 atinfo@azed.gov 

Permission to duplicate if credit retained 

Feature Organization 
Visual 

Presentation 
Cognitive 
Supports 

Physical 
Access 

Page # 

Ribbons & Quick Access X X X  1-5 

Magnifying text  X   6 

Increase font size & font choices  X   8 

Bold, underline & Text Color  x   9-10 

Increasing line, word, or character spacing  X   10 

Adjusting margins  X   10 

Changing font/background color  X   10 

AutoCorrect (Misspelled Words & Vocabulary 
Expansion) 

  X X 11 

AutoText (Headings & Reduce Keystrokes)   X X 12 

Spell check/Readability Statistics   X  13 

Thesaurus   X  15 

Footnotes/Endnotes   X  15 

SmartArt Graphics (Visual Organizers) X X X  16 

Track Changes X  X  17 

Inserting Sound Recordings (Voice Notes) X  X  19 

Proofing (definition)   X  20 

Picture Support  X X  21 

Using Drawing functions (stop signs, call outs, 
etc ) 

X  X  22 

AutoSummarize   X  23 

Highlighting X X X  24 

Document Map   X  25 

Full Read Reading View   X  26 

Hyperlinks X  X  27 

Using the Forms functions (check box, answer 
field, drop down list) 

  X X 27-31 

Reducing Mouse Movements    X 32 


